Editing workflows may not work intermittently

Incident Report for altaFlow

Resolved

The incident has been resolved. 'Edit' option is available, and no errors should pop up.
Posted Jan 15, 2026 - 15:08 UTC

Investigating

We are currently having issues with editing workflows. You can face "Ouch it's not you, it's us" error. Our team is already investigating the issue
Posted Jan 15, 2026 - 14:59 UTC
This incident affected: Web.